summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index f08b7bc62a..5d81e9a381 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
;;; Copyright © 2024 Troy Figiel <[email protected]>
;;; Copyright © 2024 Artyom V. Poptsov <[email protected]>
+;;; Copyright © 2024 Herman Rimm <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1200,6 +1201,32 @@ functions and even in applications.")
functions for writing tests in an @code{xUnit} style.")
(license license:expat)))
+(define-public go-go-abhg-dev-requiredfield
+ (package
+ (name "go-go-abhg-dev-requiredfield")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abhinav/requiredfield")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15dccs71is06wi8xi3y2nnwpcpqbsh4pas4iggdr514aix8ljknf"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "go.abhg.dev/requiredfield"))
+ (propagated-inputs
+ (list go-golang-org-x-tools))
+ (home-page "https://go.abhg.dev/requiredfield")
+ (synopsis "Linter for required struct fields")
+ (description
+ "This package implements a linter that checks for required fields during
+struct initialization.")
+ (license license:bsd-3)))
+
(define-public go-go-etcd-io-gofail
(package
(name "go-go-etcd-io-gofail")