summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 87391b4806..c68b17b0ab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -94,7 +94,7 @@
;;; Copyright © 2020, 2021 Zheng Junjie <[email protected]>
;;; Copyright © 2020 EuAndreh <[email protected]>
;;; Copyright © 2021, 2022 Morgan Smith <[email protected]>
-;;; Copyright © 2021-2023 Sharlatan Hellseher <[email protected]>
+;;; Copyright © 2021-2024 Sharlatan Hellseher <[email protected]>
;;; Copyright © 2021 Ellis Kenyő <[email protected]>
;;; Copyright © 2021 LibreMiami <[email protected]>
;;; Copyright © 2021 Xinglu Chen <[email protected]>
@@ -8836,6 +8836,29 @@ clean plots with a minimalistic style.")
complex-valued functions.")
(license license:gpl3+)))
+(define-public python-cppheaderparser
+ (package
+ (name "python-cppheaderparser")
+ (version "2.7.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "CppHeaderParser" version))
+ (sha256
+ (base32 "0hncwd9y5ayk8wa6bqhp551mcamcvh84h89ba3labc4mdm0k0arq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f)) ; no tests
+ (propagated-inputs (list python-ply))
+ (home-page "http://senexcanis.com/open-source/cppheaderparser/")
+ (synopsis
+ "Parse C++ header files and generate a data structure representing the class")
+ (description
+ "CppHeaderParser is a pure python module that will parse C++ header files
+and generate a data structure representing the class.")
+ (license license:bsd-3)))
+
(define-public python-cppy
(package
(name "python-cppy")