summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/machine-learning.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index ecc9aa3a19..4d1d49553a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1092,6 +1092,36 @@ It currently houses implementations of
")
(license license:expat))) ; MIT License
+(define-public python-pot
+ (package
+ (name "python-pot")
+ (version "0.9.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pot" version))
+ (sha256
+ (base32 "0hk0dmjgnpwka0a7gyzrcq155wzlvzcrsav3qaizyg0wymzywi4n"))
+ (snippet '(delete-file "ot/lp/emd_wrap.cpp"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-autograd
+ python-numpy
+ python-pytorch
+ python-pytorch-geometric
+ python-pymanopt
+ python-scikit-learn
+ python-scipy))
+ (native-inputs (list python-cython
+ python-setuptools
+ python-wheel))
+ (home-page "https://github.com/PythonOT/POT")
+ (synopsis "Python Optimal Transport Library")
+ (description "This Python library provides several solvers for
+optimization problems related to Optimal Transport for signal, image
+processing and machine learning.")
+ (license license:expat)))
+
(define-public python-pymanopt
(package
(name "python-pymanopt")