summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/glib.scm1
-rw-r--r--gnu/packages/patches/telepathy-glib-fix-test.patch31
3 files changed, 33 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 42f4181b0d..652ad8fa1f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2300,6 +2300,7 @@ dist_patch_DATA = \
%D%/packages/patches/telegram-desktop-unbundle-cppgir.patch \
%D%/packages/patches/telegram-desktop-unbundle-gsl.patch \
%D%/packages/patches/telegram-purple-adjust-test.patch \
+ %D%/packages/patches/telepathy-glib-fix-test.patch \
%D%/packages/patches/teuchos-remove-duplicate-using.patch \
%D%/packages/patches/texi2html-document-encoding.patch \
%D%/packages/patches/texi2html-i18n.patch \
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index e04eedb7ba..35fc812526 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1161,6 +1161,7 @@ libraries. Examples include gtk+, webkit, libsoup and many more.")
(string-append
"https://telepathy.freedesktop.org/releases/telepathy-glib/"
"telepathy-glib-" version ".tar.gz"))
+ (patches (search-patches "telepathy-glib-fix-test.patch"))
(sha256
(base32
"1w3kja8j3gz2apal79bi3hq44xk5g78aphrqbw983l6df7bp98xh"))))
diff --git a/gnu/packages/patches/telepathy-glib-fix-test.patch b/gnu/packages/patches/telepathy-glib-fix-test.patch
new file mode 100644
index 0000000000..515c31eec9
--- /dev/null
+++ b/gnu/packages/patches/telepathy-glib-fix-test.patch
@@ -0,0 +1,31 @@
+From aa858698d7ede76b3b4c825ca14b8061c24f14e1 Mon Sep 17 00:00:00 2001
+From: Mamoru TASAKA <[email protected]>
+Date: Mon, 4 Sep 2023 17:56:15 +0900
+Subject: [PATCH] test: make test-cm accepted with newer GLib
+
+With GLib 2.77.3, the key value "foo\;bar" is no longer accepted
+with g_key_file_get_string and it returns null string result.
+
+Modify key value in test file to get it accepted by new GLib.
+---
+ tests/dbus/telepathy/managers/test_manager_file.manager | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/tests/dbus/telepathy/managers/test_manager_file.manager b/tests/dbus/telepathy/managers/test_manager_file.manager
+index 426ad4a7e..bdb3f90f1 100644
+--- a/tests/dbus/telepathy/managers/test_manager_file.manager
++++ b/tests/dbus/telepathy/managers/test_manager_file.manager
+@@ -79,11 +79,9 @@ default-triply-escaped-semicolon-in-list = list\\\;of;misc;
+ param-empty-list = as
+ default-empty-list =
+
+-# this is probably technically a Desktop Entry spec violation?
+-# we should be permissive, interpreting this as either "foo\;bar" or "foo;bar"
+-# seems reasonable
++# the value is "foo\\;bar"
+ param-escaped-semicolon = s
+-default-escaped-semicolon = foo\;bar
++default-escaped-semicolon = foo\\;bar
+
+ # all the other types
+ param-object = o \ No newline at end of file