summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bittorrent.scm26
1 files changed, 2 insertions, 24 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index d12493c269..667350ad9c 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -448,13 +448,10 @@ and will take advantage of multiple processor cores where possible.")
(lambda* (#:key tests? parallel-tests? #:allow-other-keys)
(let* ((disabled-tests
'(;; Requires a non-localhost IPv4 interface.
- "test_upnp"
- ;; test_ssl needs to be run separately.
- "test_ssl"))
+ "test_upnp"))
(exclude-regex (string-append "^("
(string-join disabled-tests "|")
")$"))
- (timeout "600")
(jobs (if parallel-tests?
(number->string (parallel-job-count))
"1")))
@@ -462,26 +459,7 @@ and will take advantage of multiple processor cores where possible.")
(invoke "ctest"
"-E" exclude-regex
"-j" jobs
- "--timeout" timeout
- "--output-on-failure")
- ;; test_ssl relies on bundled TLS certificates with a fixed
- ;; expiry date. To ensure succesful builds in the future,
- ;; fake the time to be roughly that of the release.
- ;;
- ;; At the same time, faketime happens to cause
- ;; test_fast_extension, test_privacy and test_resolve_links
- ;; to hang, even with FAKETIME_ONLY_CMDS. Not sure why. So
- ;; execute only test_ssl under faketime.
- ;;
- ;; Note: The test_ssl test times out in the ci.
- ;; Temporarily disable it until that is resolved.
- ;; (invoke "faketime" "2022-10-24"
- ;; "ctest"
- ;; "-R" "^test_ssl$"
- ;; "-j" jobs
- ;; "--timeout" timeout
- ;; "--output-on-failure")
- )))))))
+ "--output-on-failure"))))))))
(inputs (list boost openssl))
(native-inputs
(list libfaketime