summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm38
1 files changed, 17 insertions, 21 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5a85f03de5..b6e4da8465 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -37821,30 +37821,26 @@ to Github via gh-pages.")
(define-public python-arpeggio
(package
(name "python-arpeggio")
- (version "2.0.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Arpeggio" version))
- (sha256
- (base32
- "0ggdsck1wpladd5bh9drhkmm86bblgk2wagrhn3sdf4v04wkic6n"))))
- (build-system python-build-system)
- (native-inputs (list python-coverage
- python-coveralls
- python-flake8
- python-mike
- python-mkdocs
- python-pytest
- python-pytest-runner
- python-twine
- python-wheel))
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Arpeggio" version))
+ (sha256
+ (base32 "00571cmdxw8w8khzscb085kfqv2hgxdzpyz4d3a2sv92dsqb5467"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/textX/Arpeggio")
(synopsis "Packrat parser interpreter for Python")
(description
- "This Python library provides a recursive descent parser with backtracking
-and memoization (a.k.a. packrat parser). Arpeggio grammars are based on PEG
-formalism. Arpeggio's main use is a foundation for a toolchain for DSL
-development but it can be used for all sorts of general purpose parsing.")
+ "This Python library provides a recursive descent parser with
+backtracking and memoization (a.k.a. packrat parser). Arpeggio grammars are
+based on PEG formalism. Arpeggio's main use is a foundation for a toolchain
+for DSL development but it can be used for all sorts of general purpose
+parsing.")
(license license:expat)))
(define-public python-flatten-json