summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/golang.scm10
-rw-r--r--gnu/packages/patches/go-github-com-urfave-cli-fix-tests.patch28
3 files changed, 6 insertions, 33 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5091f93eb8..957726989e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1506,7 +1506,6 @@ dist_patch_DATA = \
%D%/packages/patches/go-fix-script-tests.patch \
%D%/packages/patches/go-gopkg-in-yaml-v3-32bit.patch \
%D%/packages/patches/go-github-com-golang-snappy-32bit-test.patch \
- %D%/packages/patches/go-github-com-urfave-cli-fix-tests.patch \
%D%/packages/patches/go-github-com-urfave-cli-v2-fix-tests.patch \
%D%/packages/patches/go-github-com-warpfork-go-wish-fix-tests.patch \
%D%/packages/patches/go-github-com-wraparound-wrap-free-fonts.patch \
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 27f5ffa2fa..a1e4c73ef3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4212,7 +4212,7 @@ references.")
(define-public go-github-com-urfave-cli
(package
(name "go-github-com-urfave-cli")
- (version "1.22.2")
+ (version "1.22.16")
(source
(origin
(method git-fetch)
@@ -4222,11 +4222,13 @@ references.")
(file-name (git-file-name name version))
(sha256
(base32
- "10mcnvi5qmn00vpyk6si8gjka7p654wr9hac4zc9w5h3ickhvbdc"))
- (patches (search-patches "go-github-com-urfave-cli-fix-tests.patch"))))
+ "022abbjwr3g2vbyfbdc1hg09d753hfba21b69n2nkrx168ag5ahd"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/urfave/cli"))
+ (list
+ #:import-path "github.com/urfave/cli"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
(propagated-inputs
(list go-github-com-go-md2man))
(home-page "https://github.com/urfave/cli")
diff --git a/gnu/packages/patches/go-github-com-urfave-cli-fix-tests.patch b/gnu/packages/patches/go-github-com-urfave-cli-fix-tests.patch
deleted file mode 100644
index 7408d4ec16..0000000000
--- a/gnu/packages/patches/go-github-com-urfave-cli-fix-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Backported from upstream PR: https://github.com/urfave/cli/pull/1299
----
-diff --git a/app_test.go b/app_test.go
-index 33024ff..6b3aaa3 100644
---- a/app_test.go
-+++ b/app_test.go
-@@ -513,18 +513,18 @@ func TestApp_RunAsSubcommandParseFlags(t *testing.T) {
- func TestApp_RunAsSubCommandIncorrectUsage(t *testing.T) {
- a := App{
- Flags: []Flag{
-- StringFlag{Name: "--foo"},
-+ StringFlag{Name: "foo"},
- },
- Writer: bytes.NewBufferString(""),
- }
-
- set := flag.NewFlagSet("", flag.ContinueOnError)
-- _ = set.Parse([]string{"", "---foo"})
-+ _ = set.Parse([]string{"", "-bar"})
- c := &Context{flagSet: set}
-
- err := a.RunAsSubcommand(c)
-
-- expect(t, err, errors.New("bad flag syntax: ---foo"))
-+ expect(t, err.Error(), "flag provided but not defined: -bar")
- }
-
- func TestApp_CommandWithFlagBeforeTerminator(t *testing.T) {