summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/elf.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index a32339b600..74bc62a300 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -120,6 +120,17 @@
(("run-strip-strmerge.sh") "")
(("run-elflint-self.sh") "")))))
#~())
+ #$@(if (target-loongarch64?)
+ `((add-after 'unpack 'update-config-scripts
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.guess and config.sub.
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "./config"))
+ '("config.guess" "config.sub")))))
+ '())
#$@(if (system-hurd?)
#~((add-after 'unpack 'skip-tests
(lambda _
@@ -151,8 +162,10 @@
(search-patch
"elfutils-libdwfl-string-overflow.patch"))))))
#~()))))
-
- (native-inputs (list m4))
+ (native-inputs (append (if (target-loongarch64?)
+ (list config)
+ (list))
+ (list m4)))
(inputs (list xz zlib))
(home-page "https://sourceware.org/elfutils/")
(synopsis "Collection of utilities and libraries to handle ELF files and