summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm25
-rw-r--r--gnu/packages/golang.scm26
2 files changed, 25 insertions, 26 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f3eb6544c1..16d69d959f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -10162,6 +10162,31 @@ that accepts a format string. It also provides convenience wrappers for
functions in packages @code{fmt} and @code{log}.")
(license license:expat)))
+(define-public go-github-com-michiwend-gomusicbrainz
+ (package
+ (name "go-github-com-michiwend-gomusicbrainz")
+ (version "0.0.0-20181012083520-6c07e13dd396")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/michiwend/gomusicbrainz")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c13hyv34l5hm7hrwrm62s2414ivx6dbbyhb7rw90bni78q441b1"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/michiwend/gomusicbrainz"))
+ (propagated-inputs
+ (list go-github-com-michiwend-golang-pretty))
+ (home-page "https://github.com/michiwend/gomusicbrainz")
+ (synopsis "MusicBrainz WS2 client library for Golang")
+ (description
+ "Currently GoMusicBrainz provides methods to perform search and lookup
+requests. Browse requests are not supported yet.")
+ (license license:expat)))
+
(define-public go-github-com-miolini-datacounter
(package
(name "go-github-com-miolini-datacounter")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 98b45428b6..13d3dc7384 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2161,32 +2161,6 @@ methods can be called and usual operations such as indexing or arithmetic can
be performed.")
(license license:expat))))
-(define-public go-github-com-michiwend-gomusicbrainz
- (package
- (name "go-github-com-michiwend-gomusicbrainz")
- (version "0.0.0-20181012083520-6c07e13dd396")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url
- "https://github.com/michiwend/gomusicbrainz")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1c13hyv34l5hm7hrwrm62s2414ivx6dbbyhb7rw90bni78q441b1"))))
- (build-system go-build-system)
- (propagated-inputs
- (list go-github-com-michiwend-golang-pretty))
- (arguments
- `(#:import-path "github.com/michiwend/gomusicbrainz"))
- (home-page "https://github.com/michiwend/gomusicbrainz")
- (synopsis "MusicBrainz WS2 client library for Golang")
- (description "Currently GoMusicBrainz provides methods to perform search
-and lookup requests. Browse requests are not supported yet.")
- (license license:expat)))
-
(define-public go-github-com-wtolson-go-taglib
(let ((commit "6e68349ff94ecea412de7e748cb5eaa26f472777")
(revision "0"))