summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index a29a10e954..1f33259246 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -13,7 +13,7 @@
;;; Copyright © 2018 Manuel Graf <[email protected]>
;;; Copyright © 2019 Gábor Boskovits <[email protected]>
;;; Copyright © 2019, 2020 Mathieu Othacehe <[email protected]>
-;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <[email protected]>
+;;; Copyright © 2020, 2023, 2024 Janneke Nieuwenhuizen <[email protected]>
;;; Copyright © 2020 Oleg Pykhalov <[email protected]>
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <[email protected]>
;;; Copyright © 2021 Brice Waegeneire <[email protected]>
@@ -156,7 +156,12 @@ file names.
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
- '(#:configure-flags '("-DWITH_GCRYPT=ON")
+ `(#:configure-flags '("-DWITH_GCRYPT=ON"
+ ,@(if (and (%current-target-system) (target-x86-32?))
+ (list (string-append
+ "-DCMAKE_C_FLAGS=-g -O2"
+ " -Wno-incompatible-pointer-types"))
+ '()))
;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
#:tests? #f))