summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/sphinx.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index e280c06f2b..bd84a4134d 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2021 Hugo Lecomte <[email protected]>
;;; Copyright © 2021, 2022 Maxim Cournoyer <[email protected]>
;;; Copyright © 2024 Troy Figiel <[email protected]>
+;;; Copyright © 2021 Maxime Devos <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,7 +76,10 @@
"12cdy3m5c09lpf2bbxzbhm5v5y9fk7jgm94qrzggpq86waj28cms"))))
(build-system python-build-system)
(arguments
- '(#:phases
+ `(;; Make sure it is safe to use 'imagemagick' instead of
+ ;; 'imagemagick/stable' (see the comment for the "imagemagick" input).
+ #:disallowed-references (,imagemagick/stable)
+ #:phases
(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
@@ -135,7 +139,11 @@
texlive-wrapfig
texlive-xcolor))
(native-inputs
- (list imagemagick ;for "convert"
+ ;; imagemagick is added for "convert". The store item does not retain a
+ ;; reference to imagemagick, so it should be safe to use
+ ;; 'imagemagick/stable' instead of 'imagemagick'. This is enforced by
+ ;; the '#:disallowed-references' above.
+ (list imagemagick/stable
python-cython
python-html5lib
python-pytest))