summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/freedesktop.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a77dab5794..c1a84185e1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -579,9 +579,13 @@ display servers. It supports many different languages and emoji.")
(inputs
(list glib libxml2))
(native-inputs
- (list gettext-minimal pkg-config python xdgmime
- ;; For 'doc' output.
- docbook-xml-4.1.2 docbook-xsl xmlto))
+ (append
+ (if (%current-target-system)
+ (list libxml2 this-package)
+ '())
+ (list gettext-minimal pkg-config python xdgmime
+ ;; For 'doc' output.
+ docbook-xml-4.1.2 docbook-xsl xmlto)))
(outputs (list "out" "doc"))
(home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
(synopsis "Database of common MIME types")