summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 88d30e3638..a5dcfce16a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2023 Paul A. Patience <[email protected]>
;;; Copyright © 2022 Bruno Victal <[email protected]>
;;; Copyright © 2023 David Thompson <[email protected]>
+;;; Copyright © 2023 VÖRÖSKŐI András <[email protected]>
;;; Copyright © 2023 Christopher Howard <[email protected]>
;;; Copyright © 2023 Felix Lechner <[email protected]>
;;; Copyright © 2023 Evgeny Pisemsky <[email protected]>
@@ -347,6 +348,36 @@ and its related documentation.")
(base32
"1jgmfbazc2n9dnl7axhahwppyq25bvbvwx0lqplq76by97fgf9q1")))))))
+(define-public leafnode
+ (package
+ (name "leafnode")
+ (version "1.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/leafnode/leafnode/"
+ version "/leafnode-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pkryzndqaxs1ym7gs77r6x8mmzpnm5x7n2ph8ga45zn45rwwrxl"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* "Makefile.am"
+ (("/bin/sh") (which "sh"))))))))
+ (native-inputs (list autoconf automake))
+ (inputs (list pcre2))
+ (home-page "https://sourceforge.net/projects/leafnode/")
+ (synopsis "NNTP news proxy")
+ (description
+ "Leafnode is a caching Usenet news proxy that enables online newsreaders
+to read news off-line and aggregates news from various NNTP servers into
+one.")
+ ;; Most of the code is under Expat license, with some GPL, LGPL exceptions.
+ (license license:gpl2+)))
+
(define-public miniflux
(package
(name "miniflux")