summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-25 17:22:37 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:19:13 +0200
commitfc3e81d15d3c0c0f3b72cde9925441ed1d79d42d (patch)
treeb580d9ccd06c476cb4816764d9240baa907c0e1e /gnu
parentbc70f1a2b099ebd2b1b7e736dc8f4cc385317a66 (diff)
gnu: kak-lsp: Update to 18.1.1.
* gnu/packages/text-editors.scm (kak-lsp): Update to 18.1.1. [arguments]: Don't install the sources. Add a phase to remove an optional rust dependency. [cargo-inputs]: Add rust-diffs-0.5, rust-fs4-0.8, rust-indoc-2, rust-mio-1, rust-notify-debouncer-full-0.3, rust-pulldown-cmark-0.9, rust-serde-repr-0.1, rust-unicode-width-0.1. Replace rust-clap-2 with 4, rust-crossbeam-channel-0.4 with 0.5, rust-daemonize-0.4 with 0.5, rust-dirs-2 with 5, rust-itertools-0.9 with 0.13, rust-jsonrpc-core-14 with 18, rust-lsp-types-0.80 with 0.95, rust-rand-0.7 with 0.8, rust-sloggers-1 with 2, rust-toml-0.5 with 0.8, rust-whoami-0.8 with 1. Change-Id: Idcd09d95da15ab9fb34acb80a6bd4c05231b0a44
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/text-editors.scm51
1 files changed, 34 insertions, 17 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 859b297b94..bfc9566bd1 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -378,7 +378,7 @@ competitive (as in keystroke count) with Vim.")
(define-public kak-lsp
(package
(name "kak-lsp")
- (version "9.0.0")
+ (version "18.1.1")
(source
(origin
(method git-fetch)
@@ -386,32 +386,49 @@ competitive (as in keystroke count) with Vim.")
(url "https://github.com/kak-lsp/kak-lsp")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (sha256 "1wfv2fy5ga6kc51zka3pak0hq97csm2l11bz74w3n1hrf5q9nnf8")))
+ (sha256 "1dinxd3h0dllws1v28l1igvns94j91kifv1bxjds6859q22yhhpd")))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.4)
- ("rust-clap" ,rust-clap-2)
- ("rust-daemonize" ,rust-daemonize-0.4)
- ("rust-dirs" ,rust-dirs-2)
- ("rust-enum_primitive" ,rust-enum-primitive-0.1)
+ `(#:install-source? #f
+ #:cargo-inputs
+ (("rust-clap" ,rust-clap-4)
+ ("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
+ ("rust-daemonize" ,rust-daemonize-0.5)
+ ("rust-diffs" ,rust-diffs-0.5)
+ ("rust-dirs" ,rust-dirs-5)
+ ("rust-enum-primitive" ,rust-enum-primitive-0.1)
+ ("rust-fs4" ,rust-fs4-0.8)
("rust-glob" ,rust-glob-0.3)
- ("rust-itertools" ,rust-itertools-0.9)
- ("rust-lsp-types" ,rust-lsp-types-0.80)
- ("rust-jsonrpc-core" ,rust-jsonrpc-core-14)
+ ("rust-indoc" ,rust-indoc-2)
+ ("rust-itertools" ,rust-itertools-0.13)
+ ("rust-jsonrpc-core" ,rust-jsonrpc-core-18)
+ ("rust-lazy-static" ,rust-lazy-static-1)
("rust-libc" ,rust-libc-0.2)
- ("rust-rand" ,rust-rand-0.7)
+ ("rust-lsp-types" ,rust-lsp-types-0.95)
+ ("rust-mio" ,rust-mio-1)
+ ("rust-notify-debouncer-full" ,rust-notify-debouncer-full-0.3)
+ ("rust-pulldown-cmark" ,rust-pulldown-cmark-0.9)
+ ("rust-rand" ,rust-rand-0.8)
("rust-regex" ,rust-regex-1)
("rust-ropey" ,rust-ropey-1)
+ ;("rust-sentry" ,rust-sentry-0.35)
("rust-serde" ,rust-serde-1)
- ("rust-serde_derive" ,rust-serde-derive-1)
- ("rust-serde_json" ,rust-serde-json-1)
+ ("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-serde-repr" ,rust-serde-repr-0.1)
("rust-slog" ,rust-slog-2)
("rust-slog-scope" ,rust-slog-scope-4)
- ("rust-sloggers" ,rust-sloggers-1)
- ("rust-toml" ,rust-toml-0.5)
+ ("rust-sloggers" ,rust-sloggers-2)
+ ("rust-toml" ,rust-toml-0.8)
+ ("rust-unicode-width" ,rust-unicode-width-0.1)
("rust-url" ,rust-url-2)
- ("rust-whoami" ,rust-whoami-0.8))))
+ ("rust-whoami" ,rust-whoami-1))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-optional-crash-reporting
+ (lambda _
+ (substitute* "Cargo.toml"
+ ((".*sentry.*") "")))))))
(home-page "https://github.com/kak-lsp/kak-lsp")
(synopsis "Language Server Protocol (LSP) client for Kakoune")
(description