summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <[email protected]>2025-02-23 19:48:58 +0100
committerNicolas Goaziou <[email protected]>2025-02-23 21:29:11 +0100
commitf7e61117bebd4fb2a0cdaa25860fee99ebc50aa0 (patch)
tree6630f36a1d2992f1adef13027b5b822b14d43c26 /gnu
parentb154a403bf2eb8f880eab9c3ecd2c2315a4dd9d6 (diff)
gnu: Add perl-feature-compat-class.
* gnu/packages/perl.scm (perl-feature-compat-class): New variable. Change-Id: I872bb5d48df088e80591b5b9b212aba7a8df1ab3 Signed-off-by: Nicolas Goaziou <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8c24ea2674..8a1961f06a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5088,6 +5088,28 @@ interface XS for C++; it is a thin layer over plain XS.")
link Fortran libraries into C libraries.")
(license (package-license perl))))
+(define-public perl-feature-compat-class
+ (package
+ (name "perl-feature-compat-class")
+ (version "0.06")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PE/PEVANS/Feature-Compat-Class-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1hsyjza638pmmasyk6qjw9mbzjpm3cfjdrs09ww0ylarjk1z7s7q"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (propagated-inputs (list perl-object-pad))
+ (home-page "https://metacpan.org/release/Feature-Compat-Class")
+ (synopsis "Forward-compatible @code{class} syntax in Perl")
+ (description "This module provides the @code{class} keyword and related
+others (@code{method}, @code{field} and @code{ADJUST}) in a forward-compatible
+way.")
+ (license (package-license perl))))
+
(define-public perl-file-changenotify
(package
(name "perl-file-changenotify")