summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-04 15:22:06 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:14:44 +0200
commitd9b3f9d7f013f70f886b7c7b28d61345e8ff7d00 (patch)
tree74ba84641ffb4b6d37b31db5aae0e95348c166df /gnu
parent6f1ea10823ae5836f77c7cacdd1598e9a04500b2 (diff)
gnu: rust-ravif-0.6: Mark package as deprecated.
* gnu/packages/crates-graphics.scm (rust-ravif-0.6): Rename to rust-ravif-0.6.6-yanked. [source]: Add 'yanked' to the source file-name. (rust-ravif-0.6): New deprecated package pointing to rust-ravif-0.6.6-yanked. Change-Id: Id578fa4175200ec3af227f6958c6104d9a38b006
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index a951f5609b..80d0794cfd 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -3803,16 +3803,16 @@ in AVIF format (powers the @code{cavif} tool).")
#:cargo-development-inputs
(("rust-avif-parse" ,rust-avif-parse-1))))))
-(define-public rust-ravif-0.6
+(define-public rust-ravif-0.6.6-yanked
(package
(inherit rust-ravif-0.8)
(name "rust-ravif")
- (version "0.6.6")
+ (version "0.6.6") ; This version was yanked!
(source
(origin
(method url-fetch)
(uri (crate-uri "ravif" version))
- (file-name (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version "-yanked.tar.gz"))
(sha256
(base32 "0rfm63bv0q2rjyivmzlk4wma8xff6jralh7dr1bjz2aw4knm7cw1"))))
(arguments
@@ -3829,7 +3829,12 @@ in AVIF format (powers the @code{cavif} tool).")
(("rust-avif-parse" ,rust-avif-parse-0.13))))
(native-inputs
(list nasm)) ;for building rav1e
- (inputs '())))
+ (inputs '())
+ (properties '((crate-version-yanked? . #t)))))
+
+(define-public rust-ravif-0.6
+ ;; There are no non-yanked versions of this semver.
+ (deprecated-package "rust-ravif" rust-ravif-0.6.6-yanked))
(define-public rust-raw-window-handle-0.6
(package