summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-08 23:41:33 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:47 +0000
commitc0c985a53ba0a25db7f8f5e94f1a4cee66cd3d22 (patch)
tree68b110fcdd51bf6f2ea5dc2fa0ea70ac87e82690 /gnu
parente6ef4eb582346d4976758ed7c7fd1631544a28aa (diff)
gnu: unparam: Enable tests.
* gnu/packages/golang.scm (unparam) [arguments] <tests?>: Enable most of the tests. <phases>: Add 'remove-failing-test-scripts. Change-Id: I1dd75fcd2e991bd84ac042ee1a3519612fc64511
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index bd37b8f468..7af9149be7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3163,12 +3163,18 @@ That is, @code{gofumpt} is happy with a subset of the formats that
"0qrwszcmb5slbzkq3acw57b896z22zwkv6cf6ldxwlc6p179g009"))))
(build-system go-build-system)
(arguments
- `(;; FIXME: <...>-go-1.21.5/lib/go/src/runtime/cgo/cgo.go:33:8: could not
- ;; import C (no metadata for C)
- ;; <...>-go-1.21.5/lib/go/src/net/cgo_linux.go:12:8: could not import C
- ;; (no metadata for C)
- #:tests? #f
- #:import-path "mvdan.cc/unparam"))
+ (list
+ #:import-path "mvdan.cc/unparam"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'remove-failing-test-scripts
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (for-each delete-file
+ (list "testdata/script/usedas.txtar"
+ "testdata/script/stubs.txtar"
+ "testdata/script/impl.txtar"
+ "testdata/script/paramuses.txtar"))))))))
(inputs (list go-github-com-pkg-diff go-golang-org-x-tools
go-github-com-rogpeppe-go-internal))
(home-page "https://mvdan.cc/unparam/")