summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBruno Victal <[email protected]>2025-02-23 19:23:24 +0100
committerNicolas Goaziou <[email protected]>2025-02-23 21:29:10 +0100
commitbf8b3e0564fa33bad3014fa4c81ad427c2c9c842 (patch)
tree35e892ec29b42cccd2ab980f2daea1db65897d9b /gnu
parent23b068c036223e70bdea9d7d579850a1cffc02a7 (diff)
gnu: Add perl-xs-parse-sublike.
* gnu/packages/perl.scm (perl-xs-parse-sublike): New variable. Change-Id: Ibf193d78ae6fa1138d63da7b538ed49de7dc6230 Signed-off-by: Nicolas Goaziou <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5615ef71bf..83529e3719 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2023 Mădălin Ionel Patrașcu <[email protected]>
;;; Copyright © 2023 Andreas Enge <[email protected]>
;;; Copyright © 2023 Jake Leporte <[email protected]>
+;;; Copyright © 2023 Bruno Victal <[email protected]>
;;; Copyright © 2023 Nicolas Graves <[email protected]>
;;; Copyright © 2020, 2023 Tim Gesthuizen <[email protected]>
;;;
@@ -12940,6 +12941,28 @@ syntax modules that provide new perl-visible syntax, primarily for authors of
keyword plugins using the @code{PL_keyword_plugin} hook mechanism.")
(license (package-license perl))))
+(define-public perl-xs-parse-sublike
+ (package
+ (name "perl-xs-parse-sublike")
+ (version "0.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PE/PEVANS/XS-Parse-Sublike-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0m2iv6sfkkj6ckx7nprniqrj5qg2qyir8ns8l2rwmqnvxw2pqq16"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build perl-test2-suite))
+ (home-page "https://metacpan.org/release/XS-Parse-Sublike")
+ (synopsis "XS functions to assist in parsing sub-like syntax")
+ (description
+ "This module provides some XS functions to assist in writing parsers for
+@code{sub}-like syntax, primarily for authors of keyword plugins using the
+@code{PL_keyword_plugin} hook mechanism.")
+ (license (package-license perl))))
+
(define-public perl-yaml
(package
(name "perl-yaml")