summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-01-20 10:22:53 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2025-01-26 22:59:59 +0900
commitbe058cf6fcf01be49e98b8a646e1ffdb34130db6 (patch)
tree847be348675db141b92f6b0e7077dc4993cdb884 /gnu
parent826a9df7dd461639bafb32195e85d7fa4a3270b1 (diff)
gnu: dolphin-emu: Patch data.
This resolves a hang in the menu of the WaveRace game. * gnu/packages/patches/dolphin-emu-data.patch: New file. * gnu/packages/patches/libretro-dolphin-emu-data.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/emulators.scm (dolphin-emu) [source]: Apply dolphin-emu patch. (libretro-dolphin-emu) [source]: Apply libretro-dolphin-emu patch. Reviewed-by: Sou Bunnbu (宋文武) <iyzsong@member.fsf.org> Change-Id: Ie22a7bba527724179f5296a44f1874d2efdbd94c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk4
-rw-r--r--gnu/packages/emulators.scm6
-rw-r--r--gnu/packages/patches/dolphin-emu-data.patch15
-rw-r--r--gnu/packages/patches/libretro-dolphin-emu-data.patch17
4 files changed, 39 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5091f93eb8..9457fbf4cb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -19,7 +19,7 @@
# Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
# Copyright © 2018, 2019, 2020, 2021, 2022, 2024 Oleg Pykhalov <go.wigust@gmail.com>
# Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
-# Copyright © 2018, 2020, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+# Copyright © 2018, 2020-2025 Maxim Cournoyer <maxim.cournoyer@gmail.com>
# Copyright © 2019, 2020, 2021, 2022, 2024 Guillaume Le Vaillant <glv@posteo.net>
# Copyright © 2019, 2020 John Soo <jsoo1@asu.edu>
# Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
@@ -1182,6 +1182,7 @@ dist_patch_DATA = \
%D%/packages/patches/docbook2x-static-datadir-evaluation.patch \
%D%/packages/patches/doc++-include-directives.patch \
%D%/packages/patches/doc++-segfault-fix.patch \
+ %D%/packages/patches/dolphin-emu-data.patch \
%D%/packages/patches/dovecot-opensslv3.patch \
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
%D%/packages/patches/dstat-fix-crash-when-specifying-delay.patch \
@@ -1659,6 +1660,7 @@ dist_patch_DATA = \
%D%/packages/patches/libgeotiff-fix-tests-on-i386.patch \
%D%/packages/patches/libguestfs-syms.patch \
%D%/packages/patches/libobjc2-unbundle-robin-map.patch \
+ %D%/packages/patches/libretro-dolphin-emu-data.patch \
%D%/packages/patches/librewolf-use-system-wide-dir.patch \
%D%/packages/patches/libvirt-add-install-prefix.patch \
%D%/packages/patches/libziparchive-add-includes.patch \
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 43d8d2bdf7..f20b6da79b 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -337,7 +337,8 @@ console.")
(substitute* "CMakeLists.txt"
((".*add_subdirectory.*Externals/enet.*") "")
((".*add_subdirectory.*Externals/soundtouch.*") "")
- ((".*add_subdirectory.*Externals/xxhash.*") ""))))))
+ ((".*add_subdirectory.*Externals/xxhash.*") ""))))
+ (patches (search-patches "dolphin-emu-data.patch"))))
(build-system cmake-build-system)
(arguments
(list
@@ -499,7 +500,8 @@ turbo speed, networked multiplayer, and graphical enhancements.")
(file-name (git-file-name name version))
(sha256
(base32
- "1fvm6hy0ihc0j3sgv88a7ak08c0kyikmmiif827j981fy7zvglvz"))))
+ "1fvm6hy0ihc0j3sgv88a7ak08c0kyikmmiif827j981fy7zvglvz"))
+ (patches (search-patches "libretro-dolphin-emu-data.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments dolphin-emu)
((#:configure-flags flags ''())
diff --git a/gnu/packages/patches/dolphin-emu-data.patch b/gnu/packages/patches/dolphin-emu-data.patch
new file mode 100644
index 0000000000..6ba959b929
--- /dev/null
+++ b/gnu/packages/patches/dolphin-emu-data.patch
@@ -0,0 +1,15 @@
+Resolve a hang in the menu of this game.
+
+Upstream-status: https://github.com/dolphin-emu/dolphin/pull/13285
+
+diff --git a/Data/Sys/GameSettings/GWR.ini b/Data/Sys/GameSettings/GWR.ini
+new file mode 100644
+index 0000000000..fdbc0c312f
+--- /dev/null
++++ b/Data/Sys/GameSettings/GWR.ini
+@@ -0,0 +1,5 @@
++# GWR - WAVE RACE / BLUE STORM
++
++[Core]
++# Disable multi-threading to avoid a hang in the game menu.
++CPUThread = False
diff --git a/gnu/packages/patches/libretro-dolphin-emu-data.patch b/gnu/packages/patches/libretro-dolphin-emu-data.patch
new file mode 100644
index 0000000000..e98660d8ab
--- /dev/null
+++ b/gnu/packages/patches/libretro-dolphin-emu-data.patch
@@ -0,0 +1,17 @@
+Resolve a hang in the menu of this game.
+
+Upstream-status: https://github.com/libretro/dolphin/pull/337
+
+diff --git a/Data/Sys/GameSettings/GWR.ini b/Data/Sys/GameSettings/GWR.ini
+new file mode 100644
+index 0000000000..a55f4d29cd
+--- /dev/null
++++ b/Data/Sys/GameSettings/GWR.ini
+@@ -0,0 +1,7 @@
++# GWR - WAVE RACE / BLUE STORM
++
++[Core]
++# Disable multi-threading to avoid a hang in the game menu.
++# TODO: Change to 'CPUThread = False' after rebasing to latest
++# upstream (see commit 869edd5a66).
++SyncGPU = True