summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <[email protected]>2025-01-15 08:15:46 +0530
committer宋文武 <[email protected]>2025-02-02 14:55:59 +0800
commitb64d3168af697ceb2a96e7e2c62bcf418b8a586a (patch)
tree8ab6980b3957b53e43d98bea0605241089ea08af /gnu
parentb85db5febc090ab3667bc7b847b89852f6ede935 (diff)
gnu: Add fatresize.
* gnu/packages/disk.scm (fatresize): New variable. Change-Id: Iebe5d4df7e3c8b4d41f72d5774577672c9c6ba9b Signed-off-by: 宋文武 <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/disk.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 3616faf61c..f59b373fe4 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -594,6 +594,30 @@ which respectively make and check MS-DOS FAT file systems.")
and a @command{fsck.vfat} compatibility symlink for use in an initrd.")
(license (package-license dosfstools))))
+(define-public fatresize
+ (package
+ (name "fatresize")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ya-mouse/fatresize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vhz84kxfyl0q7mkqn68nvzzly0a4xgzv76m6db0bk7xyczv1qr2"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list parted))
+ (home-page "https://github.com/ya-mouse/fatresize")
+ (synopsis "Resize FAT partitions")
+ (description
+ "This package provides a tool to resize FAT partitions using libparted.")
+ (license license:gpl3+)))
+
(define-public hdparm
(package
(name "hdparm")