summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTomas Volf <[email protected]>2025-01-03 15:24:28 +0100
committerLudovic Courtès <[email protected]>2025-01-19 23:09:55 +0100
commita916555366a190999c4cdacda16f3337d1553cc4 (patch)
tree28383fd8b55b4b8bec408b9b13515f30e0488ac7 /gnu
parentaae6e533e03ce99ce3b38293e3754bca27b3defc (diff)
gnu: gnucash: Drop special case for gnc-fq-helper.
The file does not exist since 2022, and date-manip is not required for its replacement (finance-quote-wrapper). * gnu/packages/gnucash.scm (gnucash)[arguments]<#:phases>{'wrap-programs}: Remove special case for gnc-fq-helper. [inputs]: Remove perl-date-manip. Change-Id: Id88906df2bda08ae90a9aebb5deef8e4cbae6c76 Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnucash.scm21
1 files changed, 6 insertions, 15 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 7ac7cb0d8f..12a168d6fd 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -146,20 +146,12 @@
,(map (lambda (o)
(string-append o "/lib/perl5/site_perl/"
#$(package-version perl)))
- (if (string=? prog "gnc-fq-helper")
- (list
- #$@(transitive-input-references
- 'inputs
- (map (lambda (l)
- (assoc l (package-inputs this-package)))
- '("perl-finance-quote"
- "perl-date-manip"))))
- (list
- #$@(transitive-input-references
- 'inputs
- (map (lambda (l)
- (assoc l (package-inputs this-package)))
- '("perl-finance-quote")))))))))
+ (list
+ #$@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (package-inputs this-package)))
+ '("perl-finance-quote"))))))))
'("gnucash"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
@@ -192,7 +184,6 @@
libofx
libxml2
libxslt
- perl-date-manip
perl-finance-quote
perl-json
perl-json-parse