summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-05 22:28:23 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:49 +0000
commita1770a0d4aaba946c19fb11e7b122db73c5ff3b3 (patch)
tree9743da9362c735976ee28d1fc35c1b6dba802d57 /gnu
parent796e8f1d6eafb6d650bcfef45743f5f9704a2131 (diff)
gnu: go-github-com-muesli-termenv: Remove examples.
* gnu/packages/golang-xyz.scm (go-github-com-muesli-termenv) [arguments]<phases>: Add 'remove-examples. Change-Id: Ib206b6637ee06f16595528f7ef3be1053a24ccba
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 76bd712322..cab61f78a2 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6091,7 +6091,13 @@ helping you to transform blocks of text.")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/muesli/termenv"))
+ #:import-path "github.com/muesli/termenv"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
(propagated-inputs
(list go-github-com-aymanbagabas-go-osc52-v2
go-github-com-lucasb-eyer-go-colorful