summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-02-15 21:47:14 +0100
committerRicardo Wurmus <[email protected]>2025-02-15 21:56:40 +0100
commit9c540ceefda5ad0c3be073ad26cc11abf863fdf0 (patch)
tree75b9da11989d5cb79a80219eb04393a0df838b60 /gnu
parent5f95d4af6ebaea232e2461284a063e3e0e69bd85 (diff)
gnu: python-mizani: Update to 0.13.1.
* gnu/packages/python-xyz.scm (python-mizani): Update to 0.13.1. [arguments]: Add phase 'pretend-version. Change-Id: Ibe77bf5e17ce32cf0c8c8ed8b38c4c3e1cf49f98
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5f359d9c54..bb0ab777d5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5845,7 +5845,7 @@ processing tasks.")
(define-public python-mizani
(package
(name "python-mizani")
- (version "0.9.2")
+ (version "0.13.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5854,8 +5854,18 @@ processing tasks.")
(file-name (git-file-name name version))
(sha256
(base32
- "13aisfc98nvypb4mglpdphp2r627cjzpdriw4dhlx55f3b2m0dza"))))
+ "0ij0fk4w0jyyj44ij3i2j1nfa0d7dk783w9r25cpwjkpn690xqfx"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'pretend-version
+ ;; The version string is usually derived via setuptools-scm, but
+ ;; without the git metadata available, the version string is set to
+ ;; '999'.
+ (lambda _
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version))))))
(propagated-inputs
(list python-matplotlib python-numpy python-pandas python-scipy))
(native-inputs