summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-12 21:38:33 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:46 +0100
commit8ef47ccb1bb64ba2b2eee81bf78c140227c9edd8 (patch)
tree5f97aa9b52b30c3ffb2739496f37871e3b891051 /gnu
parent6adff6f1c970b709a7cc0f3f7dbb863cf44daed1 (diff)
gnu: python-cart: Add missing inputs.
* gnu/packages/python-xyz.scm (python-cart)[arguments]: Reformat. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Iaa0877d88a1296957b1c14c88f8e669c734683a3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fac7716e6f..eb5fec9470 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35776,12 +35776,15 @@ and BMI2).")
(base32 "1zycv620iljrsval5rai1wsn0hr25ddx9xhjsyy6xxrgprfxvlfi"))))
(build-system pyproject-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "unittest" "discover")))))))
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover")))))))
(propagated-inputs (list python-pycryptodome))
+ (native-inputs (list python-setuptools python-wheel))
(home-page "https://github.com/CybercentreCanada/cart")
(synopsis "Library for interacting with the CaRT file format")
(description