summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-20 20:38:14 +0000
committerSharlatan Hellseher <[email protected]>2025-01-29 23:01:01 +0000
commit85eb135cb34cf8d78b5d911699a24bdfc280f359 (patch)
tree5f67cd5fb2c6b57381074b546079eecbb23b94a4 /gnu
parent1e8363124669d9ac364aaf6209c5a1bc64732413 (diff)
gnu: python-cdflib: Update to 1.3.3.
* gnu/packages/astronomy.scm (python-cdflib): Update to 1.3.3. [native-inputs]: Remove python-astropy and python-hypothesis; add python-astropy-minimal. Change-Id: I71192f39ac63152bd919a9ba9acdd3475d744e1e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 0cecabc4b8..ff87949040 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2028,7 +2028,7 @@ bad pixel tracking throughout the reduction process.")
(define-public python-cdflib
(package
(name "python-cdflib")
- (version "1.3.2")
+ (version "1.3.3")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -2037,28 +2037,26 @@ bad pixel tracking throughout the reduction process.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0g723s5xg7vd37vlbjpgpiljd3vxwccslwzcf619zvdnc2xbcw2c"))))
+ (base32 "1b7r3hfkb3ldi02a6pzdcm4vrnz2ywsxy7zgg5jn903i4686wnsb"))))
(build-system pyproject-build-system)
(arguments
(list #:phases
#~(modify-phases %standard-phases
(add-before 'build 'set-env-version
(lambda _
- (setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
- #$version)))
+ (setenv "SETUPTOOLS_SCM_PRETEND_VERSION" #$version)))
(add-before 'check 'set-home-env
(lambda _
(setenv "HOME" (getcwd)))))))
(native-inputs
- (list python-astropy
- python-hypothesis
+ (list python-astropy-minimal
python-pytest
python-pytest-cov
python-pytest-remotedata
python-setuptools
python-setuptools-scm
- python-xarray
- python-wheel))
+ python-wheel
+ python-xarray))
(propagated-inputs
(list python-numpy))
(home-page "https://github.com/MAVENSDC/cdflib")