summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAntero Mejr <[email protected]>2023-06-04 17:42:19 +0000
committerDanny Milosavljevic <[email protected]>2024-12-22 13:16:36 +0100
commit84c765e0f39bea6ca80b75cb135ee1a92d6df5fa (patch)
treef39134eed59e35f31c3fdbf9e5b19342ace512dd /gnu
parent7bc9a96c38de5ed14af45fe53bc9acbd25fda190 (diff)
gnu: Add perl-graphviz.
* gnu/packages/perl.scm (perl-graphviz): New variable. Signed-off-by: Danny Milosavljevic <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3f3425fbcd..83a0e1c2ad 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages gd)
#:use-module (gnu packages gl)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages language)
@@ -5808,6 +5809,35 @@ internationalization functions provided by the C library.")
the abstract data structures.")
(license (package-license perl))))
+(define-public perl-graphviz
+ (package
+ (name "perl-graphviz")
+ (version "2.26")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETJ/GraphViz-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0a3kv92z9gykwgh8py5y67wygy25lijdfb97fl2g6ar6nch2apcs"))))
+ (build-system perl-build-system)
+ (inputs (list graphviz))
+ (propagated-inputs (list perl-file-which
+ perl-ipc-run
+ perl-libwww
+ perl-parse-recdescent
+ perl-xml-twig
+ perl-xml-xpath))
+ (home-page "https://metacpan.org/release/GraphViz")
+ (synopsis "Perl interface to Graphviz")
+ (description
+ "This module provides an interface to layout and image generation of
+directed and undirected graphs in a variety of formats (PostScript, PNG, etc.)
+using the @code{dot}, @code{neato}, @code{twopi}, @code{circo}, and @code{fdp}
+programs from the Graphviz project. This package is deprecated in favour of
+GraphViz2.")
+ (license license:perl-license)))
+
(define-public perl-guard
(package
(name "perl-guard")