summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-25 16:22:17 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:19:11 +0200
commit7aaa470eddfbb7f6caa69c76fbdd34d5754f0c5f (patch)
treea6f751b15bfcf094af6fd2414403e0bf0f6c554a /gnu
parentc4322de0e1365ed1bf893ddbe528e8557e8b15ae (diff)
gnu: rust-ipnet-2: Update to 2.10.1.
* gnu/packages/crates-io.scm (rust-ipnet-2): Update to 2.10.1. [cargo-inputs]: Add rust-heapless-0.5. Change-Id: I72d7df71d90081a82b1df064b8e506b5506f859a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a36a454ca8..cfd4118781 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -38297,19 +38297,19 @@ ABI compatible with @code{std} and @code{lbc}.")
(define-public rust-ipnet-2
(package
(name "rust-ipnet")
- (version "2.7.2")
+ (version "2.10.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "ipnet" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0zxmnidy5qha1i384fzjfxcsi0qvkbcp730h26q4z3dg54hyxdhj"))))
+ (base32 "025p9wm94q1w2l13hbbr4cbmfygly3a2ag8g5s618l2jhq4l3hnx"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-schemars" ,rust-schemars-0.8)
+ (("rust-heapless" ,rust-heapless-0.5)
+ ("rust-schemars" ,rust-schemars-0.8)
("rust-serde" ,rust-serde-1))
#:cargo-development-inputs
(("rust-serde-test" ,rust-serde-test-1))))