summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-02-23 09:00:37 +0100
committerRicardo Wurmus <[email protected]>2025-02-23 09:01:41 +0100
commit5030292dbafbd565922d08420b38304eca061a2a (patch)
tree834ffe390fe3a912d86e715daf61aeb1f084cdb0 /gnu
parent4317534b9a93b32ffd13bbe69fed57ffe00b5536 (diff)
gnu: python-anyio: Disable test on aarch64-linux.
* gnu/packages/python-xyz.scm (python-anyio):[arguments]: Conditionally disable one additional test. Change-Id: I5ebec446773355eda60ed3096cd05b179cfdcbaf
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1539f38bd1..18011c6b0f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32135,6 +32135,11 @@ standard error channel (stderr) in your program.")
(string-append
"not test_is_block_device"
+ ,@(cond
+ ((target-aarch64?)
+ '(" and not test_keyboardinterrupt_during_test"))
+ (#t '()))
+
;; These fail because of network (or specifically IPv6
;; network) access (see:
;; https://github.com/agronholm/anyio/issues/417).