summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-23 07:54:09 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-23 07:54:09 +0000
commit4f54185a55745ebd077bb20ef993ad35e687d5c4 (patch)
treebfe7f0f9506c1ceba88c20a222f5f8093d9a89fe /gnu
parent72ac2b3c02c006c13281f544059bc90ed8964013 (diff)
gnu: yq: Simplify.
* gnu/packages/web.scm (yq) [arguments]: Inherit from go-github-com-mikefarah-yq-v4. <import-path>: Adjust it to produce correct binary. <skip-build?>: Build it this time. <tests?>: Everything is tested in library package. <phases>: Remove 'rename-binary. Change-Id: Ib917d17e160bd379f95c2439c32905191a1aeab6
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 30d8ece70d..bed4765895 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5573,15 +5573,12 @@ JSON, XML, properties, CSV and TSV.")
(inherit go-github-com-mikefarah-yq-v4)
(name "yq")
(arguments
- (list #:install-source? #f
- #:import-path "github.com/mikefarah/yq/v4"
- #:test-subdirs #~(list ".") ; XXX: try to enable all tests
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'rename-binary
- (lambda _
- (rename-file (string-append #$output "/bin/v4")
- (string-append #$output "/bin/yq")))))))
+ (substitute-keyword-arguments
+ (package-arguments go-github-com-mikefarah-yq-v4)
+ ((#:install-source? _ #t) #f)
+ ((#:skip-build? _ #t) #f)
+ ((#:tests? _ #t) #f)
+ ((#:import-path _) "github.com/mikefarah/yq")))
(propagated-inputs '())
(inputs (package-propagated-inputs go-github-com-mikefarah-yq-v4))))