summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAntero Mejr <[email protected]>2023-06-04 17:42:13 +0000
committerDanny Milosavljevic <[email protected]>2024-12-22 13:13:22 +0100
commit37e64bc1f78897be87d338edd635d539282e8022 (patch)
tree94c31ba05ac08c441040b8feda5ad296956b7446 /gnu
parentbed8665f69f38a571106f58aa1ce866ccd142f0e (diff)
gnu: Add perl-datetime-format-sqlite.
* gnu/packages/perl.scm (perl-datetime-format-sqlite): New variable. Signed-off-by: Danny Milosavljevic <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b99b26ab8d..bae4e3da96 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3703,6 +3703,30 @@ function that is the reverse of `strftime(3)`, for `DateTime`. While
takes a string and a pattern and returns the `DateTime` object associated.")
(license license:artistic2.0)))
+(define-public perl-datetime-format-sqlite
+ (package
+ (name "perl-datetime-format-sqlite")
+ (version "0.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/C/CF/CFAERBER/DateTime-Format-SQLite-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1d4ln8x5bjpqmgnbbi2h16knfz674dsgvk6x7m60v6ykw454w7yc"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-datetime
+ perl-datetime-format-builder))
+ (home-page "https://metacpan.org/release/DateTime-Format-SQLite")
+ (synopsis "Parse and format SQLite dates and times")
+ (description
+ "This module understands the formats used by SQLite for its date,
+datetime and time functions. It can be used to parse these formats in order
+to create DateTime objects, and it can take a DateTime object and produce a
+timestring accepted by SQLite.")
+ (license license:perl-license)))
+
(define-public perl-datetime-locale
(package
(name "perl-datetime-locale")