summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <[email protected]>2025-01-02 20:54:13 +0100
committerLudovic Courtès <[email protected]>2025-02-23 23:50:22 +0100
commit12890e2412b4f16e1796366b46ce82f927dc8e98 (patch)
tree48a43955054dcfaa38654d71b8635aea18990bc8 /gnu
parentd17cd107f591e5b2f01faf6abf10ca2d80c1eb36 (diff)
gnu: Add grub-emu.
* gnu/packages/bootloaders.scm (grub-emu): New variable. Change-Id: Ia70246841e612b1fe1cb70001b9a6420cb7a63ea Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 4dab7bd0b7..01497678cd 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -475,6 +475,15 @@ menu to select one of the installed operating systems.")
(cross-binutils "arm-linux-gnueabihf")))
(package-native-inputs grub-efi)))))
+(define-public grub-emu
+ (package/inherit grub
+ (name "grub-emu")
+ (synopsis "GRand Unified Boot loader (Emu version)")
+ (arguments
+ (substitute-keyword-arguments (package-arguments grub)
+ ((#:configure-flags flags #~'())
+ #~(cons* "--with-platform=emu" #$flags))))))
+
;; Because grub searches hardcoded paths it's easiest to just build grub
;; again to make it find both grub-pc and grub-efi. There is a command
;; line argument which allows you to specify ONE platform - but