summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 12:13:04 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:33 +0800
commita4dc9c3ccd0348557eb1b94fb715f34081c9da65 (patch)
tree45e0a7faf8788328a2ed1285573dde407aa75be4 /gnu/packages
parentf4e14c1269e568dfa8b7befe2855289ed3cde6ca (diff)
gnu: xfdashboard: Switch to git source.
* gnu/packages/xfce.scm (xfdashboard)[source]: Switch to git-fetch. [arguments]: Add "--enable-maintainer-mode" to configure-flags. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: I2f9341f850c7ee4cfc0246f3f9117ec1549c5289
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/xfce.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 70ab93069f..6a2c6c905d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1253,22 +1253,21 @@ plugin for the Xfce panel.")
(package
(name "xfdashboard")
(version "1.0.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/apps/"
- name
- "/"
- (version-major+minor version)
- "/"
- name
- "-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "19a8xz6zv039j2m595v4wld3x4inidc7idfkk0pp42ffwm1l6a55"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/apps/"
+ name))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1blydl57xzqndcj1dkfxbmsaad27s7mqwwj3mmidz2dx9cikabl8"))))
(build-system gnu-build-system)
- (native-inputs (list intltool pkg-config `(,glib "bin")))
+ (arguments
+ (list #:configure-flags
+ #~(list "--enable-maintainer-mode"))) ;for enums.c, etc.
+ (native-inputs (list xfce4-dev-tools))
(inputs (list clutter
garcon
gtk+
@@ -1279,7 +1278,7 @@ plugin for the Xfce panel.")
libxfce4ui
libxinerama
xfconf))
- (home-page "https://www.xfce.org/")
+ (home-page "https://docs.xfce.org/apps/xfdashboard/")
(synopsis "Gnome shell like dashboard for Xfce")
(description
"Xfdashboard provides a GNOME shell dashboard and MacOS Mission Control