summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <[email protected]>2025-01-22 19:02:53 +0800
committerZheng Junjie <[email protected]>2025-01-22 19:21:03 +0800
commit6d54f34513f895026e8e7ba2083c13a75b597a5e (patch)
treef5c567ac1dc6759ad5fa6c5cf9e9f65e217b5957 /gnu/packages
parentdeafd4b03a0681d07f9569919d5ffe5c7f11829a (diff)
gnu: nvc: Improve package style.
* gnu/packages/fpga.scm (nvc)[source]: Use git-file-name. Remove .git to fix the redirection. [arguments]: Use G-expressions. Change-Id: I44115f13503ae5b3f82cc50cb2fc31168ea3a714
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/fpga.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 25f10f3b79..79c4ab9e07 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2023 Simon South <[email protected]>
;;; Copyright © 2024 Efraim Flashner <[email protected]>
;;; Copyright © 2024 Jakob Kirsch <[email protected]>
+;;; Copyright © 2025 Zheng Junjie <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -558,22 +559,20 @@ automated testing of HDL code.")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/nickg/nvc.git")
- (commit (string-append "r" version))))
- (file-name (string-append name "-" version "-checkout"))
+ (url "https://github.com/nickg/nvc")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
"1bcilpdd6qg0vwvbwjb4rcs0j051sc53yalxsgz8r8gm123ck40j"))))
(build-system gnu-build-system)
(arguments
- `(#:out-of-source? #t
- #:configure-flags
- '("--enable-vhpi")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'clean-up
- (lambda _
- (delete-file "autogen.sh"))))))
+ (list #:out-of-source? #t
+ #:configure-flags #~(list "--enable-vhpi")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'clean-up
+ (lambda _
+ (delete-file "autogen.sh"))))))
(native-inputs
(list automake
autoconf