summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-04 15:00:34 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:14:40 +0200
commit603f3c536a7d6543e382df4fd92a2ea55410e97d (patch)
tree9bac46493c49c7216fb617ae53e4f2def1104589 /gnu/packages
parentb0c7b8191241bdc84addb9a431e70a68e3bdf093 (diff)
gnu: Add rust-wayrs-core-1.
* gnu/packages/crates-graphics.scm (rust-wayrs-core-1): New variable. Change-Id: I09ca6f47d05701e31104e00cc86edde53d3b55a6
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-graphics.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index ce1835b8e5..196b9d20c0 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -5669,6 +5669,25 @@ crate @code{rust-wayland-client} for usable bindings.")
(description "This package provides a wayland client library.")
(license license:expat)))
+(define-public rust-wayrs-core-1
+ (package
+ (name "rust-wayrs-core")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wayrs-core" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1jf5gf60rmwky1q8g09adkl6gm8wssixnhm8vc2p1b2ksh6y78mn"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://github.com/MaxVerevkin/wayrs")
+ (synopsis "Core Wayland types for wayrs")
+ (description "This package provides the core Wayland types for wayrs.")
+ (license license:expat)))
+
(define-public rust-wayrs-proto-parser-2
(package
(name "rust-wayrs-proto-parser")