summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorKing, Spencer <[email protected]>2024-10-30 21:46:30 +0000
committerRicardo Wurmus <[email protected]>2025-01-23 16:13:29 +0100
commit582b1e16ffaa9e7066cee76c642e39278afeb6cd (patch)
treec1d06790a579d08f6ea18068b3b4c460db9729cb /gnu/packages
parentb895948fff9738135d8ae7c6ce91dcde47fbc6c7 (diff)
gnu: Add r-imola.
* gnu/packages/cran.scm (r-imola): New variable. Change-Id: I190847c8f80261c77954db242511a4e05a566695 Signed-off-by: Ricardo Wurmus <[email protected]>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f771c7b03e..5f3594fe41 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10384,6 +10384,32 @@ experiments\" (2011), Annals of Applied Statistics, Vol. 5, No. 3, 1752-1779,
by Li, Brown, Huang, and Bickel")
(license license:gpl2+)))
+(define-public r-imola
+ (package
+ (name "r-imola")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "imola" version))
+ (sha256
+ (base32 "087zdzn1vkyvqrdlwnackr6jyacrhg69q4b77s8z477kplickw8x"))))
+ (properties `((upstream-name . "imola")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-glue
+ r-htmltools
+ r-magrittr
+ r-shiny
+ r-stringi
+ r-yaml))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/pedrocoutinhosilva/imola")
+ (synopsis "CSS layouts (grid and flexbox) for R/Shiny")
+ (description
+ "This package allows users to create CSS grid and flexbox layouts for
+R/Shiny without needing to write custom CSS.")
+ (license license:expat)))
+
(define-public r-inext
(package
(name "r-inext")