summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Kehayias <[email protected]>2025-01-04 05:26:09 +0000
committerJohn Kehayias <[email protected]>2025-01-06 12:35:55 -0500
commit0b4b22b6d363d0dd0bdaee65e47bda5cac72475c (patch)
treeeb79f988df93a2d9803055b0efd6b168a0c8b93b /gnu/packages
parent8f261686ec0e5a988935e76e5495898e036f9fa7 (diff)
gnu: hyprland: Add hyprland-qtutils to inputs.
Hyprland will warn and suggest on running that it expects to find binaries from hyprland-qtutils. * gnu/packages/wm.scm (hyprland)[inputs]: Add hyprland-qtutils. [arguments]<#:phases>: Update fix-path phase. Change-Id: I54a2331181636b7aad9abdf7dfef9e1ac9c9fc3c Co-authored-by: Hilton Chain <[email protected]> Change-Id: I5ead782b0c981013f6b2cc0a9aac6102317fe285
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c44e67d975..b6c59010a8 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -169,6 +169,7 @@
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages regex)
#:use-module (gnu packages serialization)
@@ -363,7 +364,12 @@ or musca).
(("/usr") #$output)
(("\\<(addr2line|cat|lspci|nm)\\>" cmd)
(search-input-file
- inputs (string-append "bin/" cmd)))))))))
+ inputs (string-append "bin/" cmd))))
+ (substitute* '("src/Compositor.cpp"
+ "src/managers/VersionKeeperManager.cpp")
+ (("!executableExistsInPath.*\".") "false")
+ (("hyprland-update-screen" cmd)
+ (search-input-file inputs (in-vicinity "bin" cmd)))))))))
(native-inputs
(list gcc-14
hyprwayland-scanner
@@ -378,6 +384,7 @@ or musca).
hyprcursor
hyprgraphics
hyprland-protocols
+ hyprland-qtutils
hyprlang
hyprutils
libinput-minimal