summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLars Bilke <[email protected]>2025-01-28 09:51:28 +0100
committerLudovic Courtès <[email protected]>2025-01-28 14:56:13 +0100
commit72de3752f06de2a64fe8135a0839ca25534b326a (patch)
tree70f0ef6f1eb89d549a44ceebdc8ddaf1ddd45d21 /gnu/packages/xml.scm
parentac728b148fce4cbd1e1c2218ec8826f2aec5a0c4 (diff)
gnu: Add xmlpatch.
* gnu/packages/xml.scm (xmlpatch): New variable. Change-Id: I557f2dfbaadfef11c8ca592bb03ec829782fcb4e Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ea36774d36..10cd6d98fa 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -2040,3 +2040,29 @@ syntax of @code{xml:lang}, @code{xml:spec}, @code{xml:base}, and @code{xml:id} i
schema language defined by the XML Schema Recommendation Second Edition of 28 October
2004.")
(license license:w3c)))
+
+(define-public xmlpatch
+ (package
+ (name "xmlpatch")
+ (version "0.4.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ufz/xmlpatch")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10kjg7lz9p4xnv96053mj18dmc7lj7iqzx98z3aagnw6hfwdri7f"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))
+ (native-inputs (list pkg-config))
+ (inputs (list libxml2 glib))
+ (home-page "https://xmlpatch.sourceforge.net")
+ (synopsis "XML patch library")
+ (description
+ "XML Patch is a C++ library and command-line interface
+(the @command{xml-diff} and @command{xml-patch} commands) for patching XML
+files with XPath expressions.")
+ (license license:lgpl2.1+)))