summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2024-12-31 12:52:16 +0800
committer宋文武 <[email protected]>2025-01-01 10:48:34 +0800
commit2d58911b354c67bc3fb87e6689267bc0cd363028 (patch)
tree9d3993eaf4f94245e1b79f3efeabaf7e47ce093a /gnu/packages/xfce.scm
parent9655dceed924e87c1e42c1af036874d45d6d821f (diff)
gnu: orage: Switch to git source.
* gnu/packages/xfce.scm (orage)[source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: Id42b5b7895673b80a93ec358a3dc250d537a3c57
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 696afa885e..3c571a30bd 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1456,23 +1456,21 @@ memory usage graphically, and it can display processes as a tree.")
(package
(name "orage")
(version "4.18.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/apps/"
- name "/" (version-major+minor version) "/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32
- "1v5385hps6jgcw1ky9vl7w7iryp0rzxz6s4lx72rz8yg4sdv84v3"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/apps/" name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sidyq4358cp701rkfj4p0ikshf612jm5f9j4gma6h6v2dxp7gxw"))))
(build-system gnu-build-system)
(native-inputs
- (list
- `(,glib "bin") ; for dbus-binding-tool
- intltool
- pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list dbus-glib gtk+-2 libical libnotify libxfce4ui popt xfce4-panel))
- (home-page "https://www.xfce.org/projects/")
+ (home-page "https://docs.xfce.org/apps/orage/")
(synopsis "Simple calendar application with reminders")
(description
"This is a simple calendar application for the Xfce desktop. Orage has