summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2025-01-12 13:15:45 +0800
committer宋文武 <[email protected]>2025-01-12 14:18:03 +0800
commit11d0bdad961bb4924ee415607053b02c45817ab8 (patch)
tree58fb9eb6183cb157d08cee4ef34803dad542575d /gnu/packages/xfce.scm
parentd3f6610f853504bbd64b9ce0b4b1d99c6c386229 (diff)
gnu: xfce4-session: Patch paths to gdbus, xrdb and xmodmap.
Partly fixes <https://issues.guix.gnu.org/75288>. * gnu/packages/xfce.scm (xfce4-session)[inputs]: Add glib:bin, xmodmap and xrdb. [arguments]: Add 'patch-command-paths phase. Change-Id: I8b6fa52a67856320fe0a665b591282fb5a570427
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm33
1 files changed, 27 insertions, 6 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c5e5009ccf..2b22b2ce1e 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -720,13 +720,31 @@ your system in categories, so you can quickly find and launch them.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
- (list "--enable-maintainer-mode" ;for xfce4-session-settings_ui.h
- (string-append "--with-xsession-prefix=" %output)
- (string-append "--with-wayland-session-prefix=" %output))
+ (list
+ #:configure-flags
+ #~(list "--enable-maintainer-mode" ;for xfce4-session-settings_ui.h
+ (string-append "--with-xsession-prefix=" #$output)
+ (string-append "--with-wayland-session-prefix=" #$output))
;; Disable icon cache update.
#:make-flags
- '("gtk_update_icon_cache=true")))
+ #~(list "gtk_update_icon_cache=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'patch-command-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (search-command (lambda (cmd)
+ (search-input-file
+ inputs
+ (string-append "bin/" cmd)))))
+ (substitute* (string-append out "/bin/xflock4")
+ (("gdbus call")
+ (string-append (search-command "gdbus") " call")))
+ (substitute* (string-append out "/etc/xdg/xfce4/xinitrc")
+ (("[|] xrdb")
+ (string-append "| " (search-command "xrdb")))
+ (("&& xmodmap")
+ (string-append "&& " (search-command "xmodmap"))))))))))
(native-inputs
(list xfce4-dev-tools))
(inputs
@@ -737,7 +755,10 @@ your system in categories, so you can quickly find and launch them.")
libsm
libwnck
libxfce4ui
- libxfce4windowing))
+ libxfce4windowing
+ (list glib "bin")
+ xmodmap
+ xrdb))
(home-page "https://docs.xfce.org/xfce/xfce4-session/")
(synopsis "Xfce session manager")
(description