summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-23 07:42:05 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-23 07:42:12 +0000
commit72ac2b3c02c006c13281f544059bc90ed8964013 (patch)
tree2f2a154d7f075ac859fd21c3c7918eb078750ad8 /gnu/packages/web.scm
parentae32c2a201736ca4b967d1c502596f392d19b51f (diff)
gnu: go-github-com-mikefarah-yq-v4: Enable all tests.
* gnu/packages/web.scm (go-github-com-mikefarah-yq-v4) [arguments] <skip-build>: To treat it as a library. <phases>: Remove 'remove-binary, add 'fix-access-to-doc. Change-Id: Ie51ed0b6a0aad03ed15ae27b2a7516ac542de3cf
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c915f0e733..30d8ece70d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5528,14 +5528,17 @@ you'd expect.")
"0s7c8r6y5jv6wda2v3k47hawfdr9j3rwk717l6byvh5qsbbml0vd"))))
(build-system go-build-system)
(arguments
- (list #:import-path "github.com/mikefarah/yq/v4"
- #:test-subdirs #~(list ".") ; XXX: try to enable all tests
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'remove-binary
- (lambda _
- (delete-file-recursively
- (string-append #$output "/bin")))))))
+ (list
+ #:skip-build? #t
+ #:import-path "github.com/mikefarah/yq/v4"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Tests need this.
+ (add-after 'unpack 'fix-access-to-doc
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (for-each make-file-writable
+ (find-files "./pkg/yqlib/doc" "\\.md"))))))))
(propagated-inputs
(list go-github-com-a8m-envsubst
go-github-com-alecthomas-participle-v2