summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-22 01:15:40 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:14 +0000
commit795df3416677e62a52aed89d8798362e7dae3251 (patch)
tree2e473ee604bb89fa95f87fd0cb867e2b25e7b10c /gnu/packages/version-control.scm
parent9079175f05d708fd0fe17fef525bd62dc7e60c4c (diff)
gnu: go-github-com-go-git-go-git-v5: Update to 5.12.0.
* gnu/packages/version-control.scm (go-github-com-go-git-go-git-v5): Update to 5.12.0. [propagated-inputs]: Remove go-github-com-alcortesm-tgz, go-github-com-imdario-mergo, go-github-com-mitchellh-go-homedir, go-gopkg-in-check-v1, and go-gopkg-in-warnings-v0; add go-dario-cat-mergo, go-github-com-armon-go-socks5, go-github-com-elazarl-goproxy, go-github-com-gliderlabs-ssh, go-github-com-golang-groupcache, go-github-com-google-go-cmp, go-github-com-pjbgf-sha1cd, go-github-com-protonmail-go-crypto, go-github-com-skeema-knownhosts, and go-golang-org-x-sys. [native-inputs]: Remove git; add git-minimal/pinned, go-github-com-stretchr-testify, and go-gopkg-in-check-v1. Change-Id: Ifd3a6ac46a2cee8008e4b19acb9fc5adaaa6f2b7
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 304406e7be..8b0e7884fc 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -4181,7 +4181,7 @@ defects faster.")
(define-public go-github-com-go-git-go-git-v5
(package
(name "go-github-com-go-git-go-git-v5")
- (version "5.1.0")
+ (version "5.12.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4190,7 +4190,7 @@ defects faster.")
(file-name (git-file-name name version))
(sha256
(base32
- "1vkcmhh2qq8c38sjbnzf0wvg2rzr19wssaq177bsvrjwj1xz1qbs"))))
+ "1zp7d4ncgrvr420hs6nf5p66s9015y61fb4krkz4y0sl802fzj7a"))))
(build-system go-build-system)
(arguments
(list
@@ -4200,7 +4200,7 @@ defects faster.")
#~(modify-phases %standard-phases
(add-before 'build 'setup
(lambda* (#:key inputs #:allow-other-keys)
- (let* ((git #$(this-package-native-input "git"))
+ (let* ((git #$(this-package-native-input "git-minimal"))
(git-bin (string-append git "/bin"))
(git-exe (string-append git-bin "/git")))
(setenv "GIT_DIST_PATH=" git)
@@ -4208,24 +4208,32 @@ defects faster.")
(setenv "HOME" (getcwd))
(invoke git-exe "config" "--global" "user.email" "[email protected]")
(invoke git-exe "config" "--global" "user.name" "GitHub Actions")))))))
+ (native-inputs
+ (list git-minimal/pinned
+ go-github-com-stretchr-testify
+ go-gopkg-in-check-v1))
(propagated-inputs
- (list go-github-com-alcortesm-tgz
+ (list go-dario-cat-mergo
+ go-github-com-armon-go-socks5
+ go-github-com-elazarl-goproxy
go-github-com-emirpasic-gods
+ go-github-com-gliderlabs-ssh
go-github-com-go-git-gcfg
go-github-com-go-git-go-billy-v5
go-github-com-go-git-go-git-fixtures-v4
- go-github-com-imdario-mergo
+ go-github-com-golang-groupcache
+ go-github-com-google-go-cmp
go-github-com-jbenet-go-context
go-github-com-kevinburke-ssh-config
- go-github-com-mitchellh-go-homedir
+ go-github-com-pjbgf-sha1cd
+ go-github-com-protonmail-go-crypto
go-github-com-sergi-go-diff
+ go-github-com-skeema-knownhosts
go-github-com-xanzy-ssh-agent
go-golang-org-x-crypto
go-golang-org-x-net
- go-golang-org-x-text
- go-gopkg-in-check-v1
- go-gopkg-in-warnings-v0))
- (native-inputs (list git))
+ go-golang-org-x-sys
+ go-golang-org-x-text))
(home-page "https://github.com/go-git/")
(synopsis "Git implementation library")
(description "This package provides a Git implementation library.")