summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2022-07-21 23:52:47 +0200
committerMarius Bakke <[email protected]>2022-07-21 23:52:47 +0200
commitabea091dbef2d44e6eb46bd2413bdf917e14d095 (patch)
tree28f6c61dbda0acb52678944b121b66a6f50a3709 /gnu/packages/text-editors.scm
parent3b20467807c32aeac56bbbe22ffb8823f68e282b (diff)
parent3f171587bc6a47bb056f3e699e17e05f5832aea5 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 30fc375176..0c8531cc4d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -167,7 +167,7 @@ based command language.")
(define-public kakoune
(package
(name "kakoune")
- (version "2021.08.28")
+ (version "2021.11.08")
(source
(origin
(method url-fetch)
@@ -175,7 +175,7 @@ based command language.")
"releases/download/v" version "/"
"kakoune-" version ".tar.bz2"))
(sha256
- (base32 "1jvn4b9rma5jjvg3xz8nf224pbq3ry570j6qvc834wn5v3gxfvkg"))))
+ (base32 "1x5mvmpf0rgmr2xdw5wjn4hr6qd8yvj0zx588fi324x1knfqhc5a"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -191,14 +191,9 @@ based command language.")
(substitute* "src/shell_manager.cc"
(("if \\(m_shell.empty\\(\\)\\)" line)
(string-append "m_shell = \"" (which "sh")
- "\";\n " line)))
- #t))
- (delete 'configure) ; no configure script
- ;; kakoune requires us to be in the src/ directory to build.
- (add-before 'build 'chdir
- (lambda _ (chdir "src") #t)))))
- (native-inputs
- (list asciidoc pkg-config ruby))
+ "\";\n " line)))))
+ (delete 'configure)))) ; no configure script
+ (native-inputs (list pkg-config))
(synopsis "Vim-inspired code editor")
(description
"Kakoune is a code editor heavily inspired by Vim, as such most of its