summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2024-12-04 18:26:07 +0100
committerLudovic Courtès <[email protected]>2024-12-16 00:19:56 +0100
commitf8f005815efdf9f0d5d2a5ac30c6fdd19aa22e72 (patch)
tree17a61d9b3b72ca70e39ad1d7219c9a9a2e4af955 /gnu/packages/tex.scm
parente9e4b2fafd77491f1865399f09f28ebe5d71916c (diff)
packages: Use origin file names as their input labels.
* guix/packages.scm (add-input-label): Rely on 'origin-actual-file-name' for internal inputs labels. * tests/packages.scm ("this-package-input, origin"): New test. * doc/guix.texi (package Reference): Mention origin lookup for ‘lookup-package-input’ & co. * gnu/packages/base.scm (tzdata)[inputs]: Reintroduce label. * gnu/packages/tex.scm (texlive-hyphen-complete)[inputs]: Likewise. (texlive-newverbs)[native-inputs]: Likewise. Change-Id: I6ba5352b1b1b8ab810da3730b09cb9db61d6429c Co-authored-by: Simon Tournier <[email protected]>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 12 insertions, 9 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9f8cccecc8..f5dd1243ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -706,14 +706,15 @@ of user-specified directories similar to how shells look up executables.")
(string-append "File.join(\"" ptex "\"")))
(invoke "ruby" "generate-ptex-patterns.rb"))))))))
(native-inputs
- (list ruby-2.7
- ruby-hydra-minimal/pinned
- ;; Build phase requires "docstrip.tex" from TEXLIVE-LATEX.
- ;; However, adding this package to native inputs would initiate
- ;; a circular dependency. To work around this, use TEXLIVE-LATEX
- ;; source, then add "docstrip.tex" to TEXINPUTS before build.
- (package-source texlive-latex)
- texlive-tex))
+ ;; TODO: Remove input labels on next rebuild cycle.
+ `(("ruby" ,ruby-2.7)
+ ("ruby-hydra-minimal" ,ruby-hydra-minimal/pinned)
+ ;; Build phase requires "docstrip.tex" from TEXLIVE-LATEX.
+ ;; However, adding this package to native inputs would initiate
+ ;; a circular dependency. To work around this, use TEXLIVE-LATEX
+ ;; source, then add "docstrip.tex" to TEXINPUTS before build.
+ ("_" ,(package-source texlive-latex))
+ ("texlive-tex" ,texlive-tex)))
(home-page "https://ctan.org/pkg/hyph-utf8")
(synopsis "Hyphenation patterns expressed in UTF-8")
(description
@@ -65048,7 +65049,9 @@ Unicode option of @code{inputenc} or @code{inputenx}, or by XeLaTeX/LuaLaTeX.")
"tex/generic/ydoc/ydocstrip.tex")
"build/")
(setenv "TEXINPUTS" (string-append (getcwd) "/build:")))))))
- (native-inputs (list (package-source texlive-ydoc)))
+ (native-inputs
+ ;; TODO: Remove input label on next rebuild cycle.
+ `(("_" ,(package-source texlive-ydoc))))
(home-page "https://ctan.org/pkg/newverbs")
(synopsis "Define new versions of @code{\\verb}")
(description