summaryrefslogtreecommitdiff
path: root/gnu/packages/task-management.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-03-30 09:47:43 +0100
committerLiliana Marie Prikler <[email protected]>2024-03-30 09:47:43 +0100
commita915a57d91c54e926b625f98833dead8263607b0 (patch)
tree24b4b9070055733acad9b2c0bdfcda2fa5affbd4 /gnu/packages/task-management.scm
parent4b23fd7adbddc1bc18b209912c0f3ef369da2f24 (diff)
parent704e09f1626303625e1e4eea552bff3a05303e89 (diff)
Merge branch 'gnome-team'
Diffstat (limited to 'gnu/packages/task-management.scm')
-rw-r--r--gnu/packages/task-management.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index f9221f8483..96df50d747 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -443,21 +443,23 @@ on arbitrary tasks. All the time data is saved in files residing in the
(base32 "1j2h5cv8wnmw41fpz1ggsgi599qhk184cas9kgd92glj3m4alg6f"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-tests
- (lambda _
- (substitute* '("tests/test_cli.py" "tests/test_formatter.py")
- (("tests\\.helpers") "helpers"))))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests" "-k"
- (string-append
- ;; Test expects wrong output string.
- "not test_bad_start_date "
- ;; Unknown failure
- "and not test_default_command_args"))))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* '("tests/test_cli.py" "tests/test_formatter.py")
+ (("tests\\.helpers") "helpers"))))
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "--hypothesis-profile=ci"
+ "-vv" "tests" "-k"
+ (string-append
+ ;; Test expects wrong output string.
+ "not test_bad_start_date "
+ ;; Unknown failure
+ "and not test_default_command_args"))))))))
(native-inputs
(list python-setuptools-scm
python-pytest