summaryrefslogtreecommitdiff
path: root/gnu/packages/sequoia.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2021-10-01 17:10:49 -0400
committerMaxim Cournoyer <[email protected]>2021-10-01 17:10:49 -0400
commit2e65e4834a226c570866f2e8976ed7f252b45cd1 (patch)
tree21d625bce8d03627680214df4a6622bf8eb79dc9 /gnu/packages/sequoia.scm
parent9c68ecb24dd1660ce736cdcdea0422a73ec318a2 (diff)
parentf1a3c11407b52004e523ec5de20d326c5661681f (diff)
Merge remote-tracking branch 'origin/master' into staging
With resolved conflicts in: gnu/packages/bittorrent.scm gnu/packages/databases.scm gnu/packages/geo.scm gnu/packages/gnupg.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/linux.scm gnu/packages/python-xyz.scm gnu/packages/xorg.scm guix/build/qt-utils.scm
Diffstat (limited to 'gnu/packages/sequoia.scm')
-rw-r--r--gnu/packages/sequoia.scm95
1 files changed, 17 insertions, 78 deletions
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index b75a622c64..2c68f43e36 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019, 2020 Hartmut Goebel <[email protected]>
+;;; Copyright © 2019, 2020, 2021 Hartmut Goebel <[email protected]>
;;; Copyright © 2021 Efraim Flashner <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -42,15 +42,15 @@
(define-public sequoia
(package
(name "sequoia")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://gitlab.com/sequoia-pgp/sequoia.git")
- (commit (string-append "v" version))))
+ (commit (string-append "openpgp/v" version))))
(sha256
- (base32 "0y80bl786m29ww3272qsl1ql0xc3pwd6iiqlkv3nmhnjsmygbn0d"))
+ (base32 "0knkm0nw1h4ww51vks4jnnp1yc45llfi7j0i70f6vf2bcknnbmci"))
(file-name (git-file-name name version))))
(build-system cargo-build-system)
(outputs '("out" "python"))
@@ -140,12 +140,25 @@
;; Run make instead of using the rust build system, as
;; suggested by the installation instructions
(replace 'build (lambda _ (invoke "make" "build-release") #t))
+ (delete 'package) ;; cargo can't package a multi-crate workspace
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(if tests?
(invoke "make" "check")
#t)))
(replace 'install (lambda _ (invoke "make" "install") #t))
+ (add-after 'unpack 'fix-rand-dependency
+ (lambda _
+ (substitute* "ipc/Cargo.toml"
+ ;; required: enable rand::rngs::OsRng in rand >= 0.8
+ (("(^rand =.*,) default-features = false(.*)" _ a b)
+ (string-append a " features = [\"getrandom\"]" b)))
+ #t))
+ (add-after 'unpack 'fix-permissions
+ (lambda _
+ (chmod "sq/src/sq-usage.rs" #o644)
+ (chmod "sqv/src/sqv-usage.rs" #o644)
+ #t))
(add-after 'unpack 'fix-environment
(lambda* (#:key outputs #:allow-other-keys)
;; adjust prefix
@@ -205,77 +218,3 @@
several crates, providing both a low-level and a high-level API for dealing
with OpenPGP data.")
(license license:gpl2+)))
-
-(define-public sequoia4pEp
- ;; Currently pEp Engine requires sequoia in not-so-current version
- (package/inherit sequoia
- (name "sequoia")
- (version "0.15.0-pEp")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/sequoia-pgp/sequoia.git")
- (commit "0eb1b6cd846ea8c36b3dfdf01ec88383fc64f2fe")))
- (sha256
- (base32 "06dqs9whwp9lfibwp8dqm0aw4nm3s3v4jp2n4fz51zcvsld40nfh"))
- (file-name (git-file-name name version))))
- (arguments
- (substitute-keyword-arguments (package-arguments sequoia)
- ((#:cargo-inputs _)
- `(("rust-anyhow" ,rust-anyhow-1)
- ("rust-base64" ,rust-base64-0.11)
- ("rust-bzip2" ,rust-bzip2-0.3)
- ("rust-capnp" ,rust-capnp-0.10)
- ("rust-capnp-rpc" ,rust-capnp-rpc-0.10)
- ("rust-chrono" ,rust-chrono-0.4)
- ("rust-clap" ,rust-clap-2)
- ("rust-crossterm" ,rust-crossterm-0.13)
- ("rust-dirs" ,rust-dirs-2)
- ("rust-flate2" ,rust-flate2-1)
- ("rust-fs2" ,rust-fs2-0.4)
- ("rust-futures" ,rust-futures-0.1)
- ("rust-http" ,rust-http-0.1)
- ("rust-hyper" ,rust-hyper-0.12)
- ("rust-hyper-tls" ,rust-hyper-tls-0.3)
- ("rust-idna" ,rust-idna-0.2)
- ("rust-itertools" ,rust-itertools-0.8)
- ("rust-lalrpop" ,rust-lalrpop-0.17)
- ("rust-lalrpop-util" ,rust-lalrpop-util-0.17)
- ("rust-lazy-static" ,rust-lazy-static-1)
- ("rust-libc" ,rust-libc-0.2)
- ("rust-memsec" ,rust-memsec-0.5)
- ("rust-native-tls" ,rust-native-tls-0.2)
- ("rust-nettle" ,rust-nettle-7)
- ("rust-percent-encoding" ,rust-percent-encoding-2)
- ("rust-prettytable-rs" ,rust-prettytable-rs-0.8)
- ("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quickcheck" ,rust-quickcheck-0.9)
- ("rust-quote" ,rust-quote-1)
- ("rust-rand" ,rust-rand-0.7)
- ("rust-regex" ,rust-regex-1)
- ("rust-rpassword" ,rust-rpassword-4)
- ("rust-rusqlite" ,rust-rusqlite-0.19)
- ("rust-sha2" ,rust-sha2-0.8)
- ("rust-syn" ,rust-syn-1)
- ("rust-tempfile" ,rust-tempfile-3)
- ("rust-thiserror" ,rust-thiserror-1)
- ("rust-tokio" ,rust-tokio-0.1)
- ("rust-tokio-core" ,rust-tokio-core-0.1)
- ("rust-tokio-io" ,rust-tokio-io-0.1)
- ("rust-unicode-normalization" ,rust-unicode-normalization-0.1)
- ("rust-url" ,rust-url-2)
- ("rust-zbase32" ,rust-zbase32-0.1)))
- ((#:cargo-development-inputs _)
- `(("rust-assert-cli" ,rust-assert-cli-0.6)
- ("rust-colored" ,rust-colored-1)
- ("rust-filetime" ,rust-filetime-0.2)))
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'unpin-deps
- (lambda _
- (substitute* (find-files "." "Cargo.toml")
- (("= \"<") "= \"")
- (("= \"=") "= \""))
- #t))))))
- (properties `((hidden? . #t)))))