summaryrefslogtreecommitdiff
path: root/gnu/packages/sagemath.scm
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2020-01-21 21:34:41 +0100
committerMarius Bakke <[email protected]>2020-01-21 21:34:41 +0100
commit715110a8a2e9e4b1a89635950744eb5260b8ee7f (patch)
tree0d0e4c41631092a068d8b0823f4d6b0a8d725eed /gnu/packages/sagemath.scm
parentb3c2ebda5bcedcfb88475e53b7f36c3a42cac8b4 (diff)
parent79e074ea10875ff75ca613179c70de12d64b19f5 (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/sagemath.scm')
-rw-r--r--gnu/packages/sagemath.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index a749f5633a..2cc50f7b6a 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Andreas Enge <[email protected]>
;;; Copyright © 2019 Nicolas Goaziou <[email protected]>
-;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -275,7 +275,7 @@ on numerical types, while GiNaC depends on CLN for this purpose.")
(define-public zn-poly
(package
(name "zn-poly")
- (version "0.9.1")
+ (version "0.9.2")
(source
(origin
(method git-fetch)
@@ -285,8 +285,7 @@ on numerical types, while GiNaC depends on CLN for this purpose.")
(commit version)))
(file-name (git-file-name "zn_poly" version))
(sha256
- (base32
- "0ra5vy585bqq7g3317iw6fp44iqgqvds3j0l1va6mswimypq4vxb"))))
+ (base32 "1wbc3apxcldxfcw1dnwnn7fvlfb6bwvlr8glvgv6hf79p9r2s4j0"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python-2)))
@@ -332,7 +331,7 @@ coefficients of which are modular integers.")
(define-public brial
(package
(name "brial")
- (version "1.2.5")
+ (version "1.2.6")
(source
(origin
(method git-fetch)
@@ -341,8 +340,7 @@ coefficients of which are modular integers.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1nv56fp3brpzanxj7vwvxqdafqfsfhdgq5imr3m94psw5gdfqwja"))))
+ (base32 "1mc1zjr3mxcx6bg0js5k9jx65japg7644b0aj1al75m4nwh2ygab"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -365,7 +363,7 @@ for the underlying polynomial rings and subsets of the powerset of the
Boolean variables. As a unique approach, binary decision diagrams are
used as internal storage type for polynomial structures.")
(license license:gpl2+)
- (home-page "https://gitlab.com/sagemath/zn_poly")))
+ (home-page "https://github.com/BRiAl/BRiAl/")))
(define-public lcalc
(package