summaryrefslogtreecommitdiff
path: root/gnu/packages/readline.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2021-10-01 17:10:49 -0400
committerMaxim Cournoyer <[email protected]>2021-10-01 17:10:49 -0400
commit2e65e4834a226c570866f2e8976ed7f252b45cd1 (patch)
tree21d625bce8d03627680214df4a6622bf8eb79dc9 /gnu/packages/readline.scm
parent9c68ecb24dd1660ce736cdcdea0422a73ec318a2 (diff)
parentf1a3c11407b52004e523ec5de20d326c5661681f (diff)
Merge remote-tracking branch 'origin/master' into staging
With resolved conflicts in: gnu/packages/bittorrent.scm gnu/packages/databases.scm gnu/packages/geo.scm gnu/packages/gnupg.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/linux.scm gnu/packages/python-xyz.scm gnu/packages/xorg.scm guix/build/qt-utils.scm
Diffstat (limited to 'gnu/packages/readline.scm')
-rw-r--r--gnu/packages/readline.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/readline.scm b/gnu/packages/readline.scm
index 8a36883347..c7db9e611d 100644
--- a/gnu/packages/readline.scm
+++ b/gnu/packages/readline.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2020 Ludovic Courtès <[email protected]>
;;; Copyright © 2016, 2019 Efraim Flashner <[email protected]>
;;; Copyright © 2016 Jan Nieuwenhuizen <[email protected]>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
+;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019 Marius Bakke <[email protected]>
;;;
;;; This file is part of GNU Guix.
@@ -23,10 +23,12 @@
(define-module (gnu packages readline)
#:use-module (guix licenses)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix utils)
#:use-module (ice-9 format))
@@ -144,19 +146,21 @@ comfortable for anyone.")
(define-public rlwrap
(package
(name "rlwrap")
- (version "0.43")
+ (version "0.45.2")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/hanslub42/rlwrap/releases/"
- "download/v" version "/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "0bzb7ylk2770iv59v2d0gypb21y2xn87m299s9rqm6rdi2vx11lf"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hanslub42/rlwrap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1irlcdvj1ddxkfzwa7l2djxgp5xbqch9vaajk2s32x1h5cxl1f5r"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("perl" ,perl)))
(inputs
`(("readline" ,readline)))
(synopsis "Wrapper to allow the editing of keyboard commands")
@@ -165,6 +169,6 @@ comfortable for anyone.")
readline library to allow the editing of keyboard input for any command. You
should consider rlwrap especially when you need user-defined completion (by way
of completion word lists) and persistent history, or if you want to program
-'special effects' using the filter mechanism.")
+`special effects' using the filter mechanism.")
(home-page "https://github.com/hanslub42/rlwrap")
(license gpl2+)))