summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2025-01-26 12:27:09 +0000
committerLudovic Courtès <ludo@gnu.org>2025-02-24 23:33:52 +0100
commiteaf538df401aa7706b1cb865ca8ca88283863165 (patch)
treeba767a7b443e5465d6095f0c644e8cd7e8e45588 /gnu/packages/python-xyz.scm
parentab65d8bc09e284d7ceb36263fa97f2babad70412 (diff)
gnu: Add python-merge3.
* gnu/packages/python-xyz.scm (python-merge3): New variable. Change-Id: If3238c86bb3c9b380facd02a238f5ebecc74d3de Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12aa0079ac..34d20dda8a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9928,6 +9928,24 @@ algorithm. Patiencediff provides a good balance of performance, nice output for
humans, and implementation simplicity.")
(license license:gpl2+)))
+(define-public python-merge3
+ (package
+ (name "python-merge3")
+ (version "0.0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "merge3" version))
+ (sha256
+ (base32 "1brb97v24i5ym3cfxsv416a0m1n78s1aqllmwg4xymjdv09w5snk"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/breezy-team/merge3")
+ (synopsis "Python implementation of 3-way merge")
+ (description
+ "This Python library implements 3-way merge for text.")
+ (license license:gpl2+)))
+
(define-public python-wmctrl
(package
(name "python-wmctrl")