summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-22 20:40:21 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:30 +0000
commite0ea00b05e5bebe4f1483b02321964c03d13147a (patch)
treebd29256066bfdca90d6b06f396cc5389a1bb2522 /gnu/packages/python-xyz.scm
parente5a6faeb123c92678d941d6dd7dca3dd8c5c95e7 (diff)
gnu: python-executing: Update to 2.1.0.
* gnu/packages/python-xyz.scm (python-executing): Update to 2.1.0. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-asttokens, python-littleutils, python-pytest, python-setuptools, and python-wheel. Change-Id: I912a0dea949aca618d3f728e19dc27bbbfbc40c3
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 78f924af88..5092a8a17e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10961,18 +10961,26 @@ writable properties, cached properties, etc.")
(define-public python-executing
(package
(name "python-executing")
- (version "0.8.2")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "executing" version))
(sha256
- (base32 "08q0xh9fd8k41sqpp23q6fb9bf7yj4y2q6sv30pj36vvk8pg8fy2"))))
- (build-system python-build-system)
+ (base32 "1axrwh7kr7nshzjw6vj9w9hn3rqh9af2c257ll7iba0d4vfpv8lf"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #f)) ; TODO: tests require python-asttokens
+ (list
+ ;; AssertionError: assert 'test failure' in ''
+ #:test-flags #~(list "-k" "not test_two_statement_lookups")))
(native-inputs
- (list python-setuptools-scm python-toml))
+ (list python-asttokens
+ python-littleutils
+ python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-toml
+ python-wheel))
(home-page "https://github.com/alexmojaki/executing")
(synopsis "Get information about what a Python frame is currently doing")
(description "This package lets you get information about what a frame is