summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-17 23:04:21 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:26 +0000
commit86a4de513c6911d55be73ce9af0696e82bfac76b (patch)
tree36ce2210a8f9da21b7c57269c39453f4b09d8eb5 /gnu/packages/python-xyz.scm
parent4ccbd13be0ca98b262a63a4ad24d4a82f479d238 (diff)
gnu: python-apispec-webframeworks: Update to 1.2.0.
* gnu/packages/python-xyz.scm (python-apispec-webframeworks): Update to 1.2.0. Improve package style. [source]: Adjust URI as it's changed in PyPI. [propagated-inputs]: Remove python-setuptools. [native-inputs]: Remove python-flake8, python-flake8-bugbear, python-mock, and python-tox; add python-aiohttp and python-flit-core. Change-Id: I5dd727f729192290f449fd56ff32a13d77de7bed
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30c8a724ef..b18d624326 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26148,26 +26148,25 @@ currently supports the OpenAPI specification, formerly known as Swagger.")
(define-public python-apispec-webframeworks
(package
(name "python-apispec-webframeworks")
- (version "0.5.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "apispec-webframeworks" version))
- (sha256
- (base32
- "1wyw30402xq2a8icrsjmy9v43jyvawcjd85ccb2zicqlg4k5pcqd"))))
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "apispec_webframeworks" version))
+ (sha256
+ (base32 "10gxjwmk8w67b7vcivcky4hrpv1gx8acrshnyp1169va4s62i2an"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-apispec python-setuptools))
(native-inputs
- (list python-bottle
- python-flake8
- python-flake8-bugbear
+ (list python-aiohttp
+ python-flit-core
+ python-bottle
python-flask
- python-mock
python-pytest
python-pyyaml
python-tornado
- python-tox
python-wheel))
+ (propagated-inputs
+ (list python-apispec))
(home-page "https://github.com/marshmallow-code/apispec-webframeworks")
(synopsis "Web framework plugins for apispec")
(description "This package provides plugins for using @code{apispec} with